Blog

Buggy wget again causing issues with Fantastico – Tells you installed, but fools you

Tags: cPanelFantasticoLinuxwget

Published on: April 14, 2009 by Faheem P.

Buggy wget again causing issues with Fantastico – Tells you installed, but fools you

Scenario:

Once upon a time, long back around 24 months back, there was an issue with wget and fantastico. The Issue was that fantastico will get installed. At least it will tell you that it fantastico installation has completed. But later on when you try to adjust the feature set, it will fool you saying it is not installed. We thought it got solved in 5.2. but it looks like re-appeared in RHEL/CentOS 5.3. The issue is with the buggy wget.

So the solution is to install it from source. Source is the best. RPMs and Debs took all the fun we had in slackware age of floppy based linux 🙂

cd
mkdir ssages
wget http://ftp.gnu.org/gnu/wget/wget-latest.tar.gz
yum remove wget
tar xfz wget-latest.tar.gz
cd wget-*
./configure –prefix=/usr
make
make test
make install
cd ../
rm -Rf wget-*

You will also want to put wget* on /etc/yum.conf exclude= line so the OS doesn’t automatically reinstall the buggy version.

Ref: http://www.netenberg.com/forum/index.php?topic=5430.0

Category : cPanel, Linux

Faheem P.

Faheem P.

Faheem enjoys learning new technologies and loves to implement cutting edge solutions. He is one of the most active member in various technical forums and is a familiar face in various brain storming sessions. He takes great pride in being an explorer and the best thing you can be sure about in his room is the backpack!!

You may also read:

Comments

Add new commentSIGN IN

Let's Connect

Get new updates

Categories

$0.000 items